欢迎访问 如意编程网!

如意编程网

当前位置: 首页 > 编程资源 > 编程问答 >内容正文

编程问答

error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MDd_DynamicDebug”不匹配值“MD_DynamicRelease”...

发布时间:2024/7/5 编程问答 0 豆豆
如意编程网 收集整理的这篇文章主要介绍了 error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MDd_DynamicDebug”不匹配值“MD_DynamicRelease”... 小编觉得挺不错的,现在分享给大家,帮大家做个参考.

 

1.错误提示与原因分析

或者是提示:error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2。

此类问题出现的根本原因就是,你引用的lib库的debug或release版本,与本工程的dubug或release版本不符合。这类问题在引用文件时要注意版本的匹配。

 

2.解决

此问题,应该分不同的情况去解决。

2.1 设置运行库

是几个工程的 运行库设置不一样?

此时的解决方法:

项目属性 -> 配置属性 -> C/C++ -> 代码生成 -> 运行库

都设置一样就行了 多线程调试(/MD)

 

release下,在库版本匹配没有问题。但是编译报错error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项:  值“0”不匹配值“2”。

原因是:我release下,工程设置中运行库中设置成了"多线程调试 DLL (/MDd)"。这个是设置应该是在debug下的设置,release下应该设置“多线程 DLL (/MD)”。

 

 

2.2  更改链接器输入的lib的debug版本为release版本

同样,会有如下提示,检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“2”不匹配值“0”

 以上提示的现象是当前工程是Release版本,而引用的库文件时Debug版本,只需要把当前的Release模式改成Debug模式就可以了。

 

打开解决方案--》属性--》链接器--》输入--》附加依赖项中引用Release版本的lib文件名称。

示例如下:

   

 

 

参考文章

error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MDd_DynamicDebug”不匹配值“MTd_StaticDebug”

error LNK2038: 检测到“_ITERATOR_DEBUG_LEVEL”的不匹配项: 值“0”不匹配值“2,言止予思, 2017-2

转载于:https://www.cnblogs.com/arxive/p/11220854.html

总结

以上是如意编程网为你收集整理的error LNK2038: 检测到“RuntimeLibrary”的不匹配项: 值“MDd_DynamicDebug”不匹配值“MD_DynamicRelease”...的全部内容,希望文章能够帮你解决所遇到的问题。

如果觉得如意编程网网站内容还不错,欢迎将如意编程网推荐给好友。